Mobile App / Precision Feed Issues
Incident Report for
BarnTools
Resolved
The issues have been resolved.
Posted
Jun
19
,
2026
-
09:29
CDT
Investigating
We are receiving some reports of issues within the mobile app and precision feed. Our engineering team is investigating.
Posted
Jun
19
,
2026
-
09:08
CDT
This incident affected: BarnTalk.
×
Subscribe to Incident
Subscribe to updates for
Mobile App / Precision Feed Issues
via . You'll receive .